Artículo BIT
Efecto 2ooo En Internet: feliz Nochevieja
Rincón de Internet Efecto 2ooo En Internet: feliz Nochevieja -------------------------------------------------------------------------------- Si no fuera porque Arthur C. Clarke y Stanley Kubrick idearon novela y película a finales de la década de los 60, que es cuando casualmente se estaba gestando este efecto, podríamos pensar que con esta afirmación, el ordenador de a bordo de la nave Discovery no estaba sino recordando al comandante Dave Bowman lo que había pasado un año antes Se ha hablado ya mucho del año 2.000 y no es nuestra intención ponernos en tono catastrofista como suele ser habitual. Más bien el artículo pretende seguir dos líneas diferenciadas. Por un lado comentaremos brevemente la problemática del año 2.000 (o Y2K como dicen algunos) en Internet, y por otro citaremos algunos de los muchos recursos que hay en la Red dedicados a este tema que consideramos de utilidad. Es bien conocido de todos el problema. En tiempos en que los recursos de memoria eran muy valiosos, ¿para qué representar los años en campos con cuatro dígitos, pudiendo hacerlo sólo con los dos últimos?. No se pensó en que podría pasar con la venida del nuevo milenio. Pero el año 2.000 ya está aquí y por desgracia no todos los potenciales problemas están resueltos. Cómo afectará el año 2.000 a la Red Cuando se oye hablar del efecto 2.000, se suele vincular a aplicaciones administrativas y financieras, muchas de las cuales han sido escritas en lenguajes como Cóbol. Sin embargo este efecto también toca Internet en diversos aspectos. Así, nos encontramos con las diferentes máquinas conectadas a la red como routers, switches...cuyo HW, propietario en muchos casos, puede incluir incompatibilidades en su SW de ROM. También ciertas aplicaciones relacionadas con Internet (como, por ejemplo los programas de correo electrónico) podrían presentar alguna incompatibilidad con el Año 2.000. (En este caso el problema parece que no presentaría mayor trascendencia que la incorrecta ordenación de los mensajes en las bandejas al pasar a representar como 00 el Año 2000 y sucesivos). En lo referente a los protocolos, la IETF (Internet Enginering Task Force) ha constituido un grupo de trabajo que ha llevado a cabo un estudio en el que se han analizado pormenorizadamente los distintos RFCs (Request for Comments series) de la Internet. El resultado es que si bien no se han encontrado serios problemas que hagan peligrar la existencia de la Red si que han aparecido ligeras dicrepancias. Para ello se ha divido el estudio en 12 áreas de protocolos. Pasamos a extractar brevemente, por áreas, las conclusiones del informe: Autoconfiguración, BOOT Protocol y DHCP (Dynamic Host Configuration Protocol).- No presentan problemas. Servicios de Directorio, X.500: Whois, Rwhois, Whois++ y LDAP (Lightweight Directory Access Protocol).- Se encuentra alguna discrepancia menor, pero ningún problema serio (RFCs 1274, 1276, 1488, 1608, 1609 y 1778). Network File System (NFS).- No presenta problemas. IRC (Internet Relay Chat).- Tampoco habrá problemas. Servicios de información, FTP y WWW.- HTTP1.1 acepta formatos de fechas que no cumplen con el año 2000 (RFC 850). Asimismo HTML 2.0 podría presentar algún problema menor (RFC 1866) y también las representaciones en cadenas de sintaxis de atributos estándar (RFC 1778). "Recordad: Nadie mueve ni un dedo hasta que el reloj de las doce campanadas" "Tenemos un problema, señor. Están ensayando pruebas Y2K" Capas de red y transporte: Protocolos IP (Internet Protocol), TCP (Trasnmission Control Protocol), UDP (User Datagram Protocol), PPP (Point to Point Protocol) y sus extensiones, ICMP (Internet Control Message Protocol), ARP (Address Resolution Protocol), y RPC (Remote Procedure Call).- No se han encontrado problemas de compatibilidad con el Año 2000. Correo electrónico: SMTP (Single Mail Transfer Protocol), IMAP (Internet Mail Access Protocol), POP (Post Office Protocol) MIME (Multipurpose Internet Mail Exhange) e interacción X.400 a SMTP.- Aunque algunos estándares originalmente se basaban en representaciones del año de dos dígitos, se concluye que todos los estándares actualmente utilizados precisan años de 4 dígitos. NTP (Network Time Protocol).- Cumple con el año 2.000. DNS (Domain Name System).- No se han encontrado problemas referentes al año 2.000 aunque en aspectos de seguridad le afecta el problema del año 2.038 Gestión de red: Protocolo SNMP (Simple Network Management Protocol), un gran número de MIBs (Management Information Bases) y CMOT (Common Management Information Protocol over TCP/IP).- Se han encontrado unas pequeñas discrepancias, pero ninguna de ellas parece tener impacto en la interoperatividad. News.- Existe un problema tanto en el NNTP (Network News Protocol-RFC 977) como en el Usenet News Message Format (RFC 10336), pues ambos emplean un formato de año en dos dígitos. Servicios de tiempo real: IP Multicast, RTP e Internet Stream Protocol.- Presentan un problema en el SNPP (Simple Network Paging Protocol) versiones 2 y 3 que utiliza un campo para el año de dos dígitos. Enrutado.- Los protocolos RIP (Routing Information Protocol) y BGP (Border Gateway Protocol) cumplen con el Año 2000. A IDRP (InterDomain Routing Protocol) le afecta el problema del año 2038 Seguridad: Protocolo de autenticación Kerberos, RADIUS (Remote Authentication Dial In User Service), OTP (One Time Password System), PEM (Privacy Enhanced Mail), extensiones de seguridad a protocolos diversos(RIPv2, HTTP, MIME, PPP, IP, Telnet y FTP) y algoritmos de cifrado y autenticación.- Podrían existir algunos problemas con DASS (Distributed Authentication Security Services – RFC 1507) y con PEM (Privacy Enhanced Mail – RFCs 1421-1424) debido al formato del año en dos dígitos. Terminales virtuales (Telnet).- Telnet sin encriptar y TN3270 cumplen ambos con el Año 2.000. En los casos en los que se encuentran discrepancias, se han constituido grupos de trabajo en el seno de la IETF de cara a actualizar los protocolos afectados y resolver, en la medida de los posible, los potenciales problemas. Para una referencia más completa y detallada podemos consultar en la red los estudios que la International Engineering Task Force (IETF) está llevando a cabo sobre este tema. 29/12/1999. 23h: Escuchen todos: No quiero tener que repetir la importania del factor tiempo en esta misión" Pero en cualquier caso, concluiríamos quitando hierro al tema, pues se han difundido muchos rumores (como es el caso de la presunta incompatibilidad de las primeras versiones de Java) que luego no han hecho sino engrosar la cartera de leyendas urbanas que circulan por la Red. "Los Exitos del Milenio" Plan de acción Ahora ya centrándonos en el cumplimiento con el año 2.000 de forma general, hemos de decir que todavía hay tiempo, en la mayoría de los casos, para elaborar y poner en marcha un plan de acción de cara a afrontar el problema. Pero eso sí, conviene ponerse manos a la obra cuanto antes e Internet puede servirnos de ayuda a la hora de llevarlo a cabo. El planteamiento de un plan genérico: Pero eso sí, conviene ponerse manos a la obra cuanto antes e Internet puede servirnos de ayuda a la hora de llevarlo a cabo. El planteamiento de un plan genérico: 1) Realización de un inventario completo y detallado de todos los sistemas de información. Equipos hardware, software básico o de sistema, aplicaciones - paquetes estándar y programas a medida - (es importante reflejar la versión en cualquier caso), ficheros de datos (reflejando especialmente aquellos que puedan contener campos anuales de dos dígitos), sistemas de comunicaciones y resto de sistemas que puedan resultar afectados. 2) Recogida de información. Bien sea contactando con los proveedores de los sistemas recogidos en el paso anterior, bien accediendo a través de Internet a los enlaces que las distintas compañías suministradoras dedican en sus websites al efecto 2000. Algunos incluso ponen a disposición pública herramientas de evaluación del efecto en sus sistemas. 3) Adaptación o sustitución de los sistemas afectados. Para esta operación en los websites de los proveedores también podremos encontrar en muchos casos parches o aplicaciones para atacar el problema. Si aún así, el sistema no puede ser adaptado, puede ser un buen momento para pensar en su sustitución. 4) Evaluación. Habrá que realizar pruebas exhaustivas de funcionamiento en los diferentes sistemas involucrados. También se pueden encontrar en Internet herramientas para este fin. 5) Preparación de un plan de contingencia. Por si pese a lo anterior, algún sistema no funcionara correctamente habría que tener un preparado un plan de contingencia para el 1 de Enero del 2000. La Federal Communications Commission Y2K (FCC) ofrece en su web un plan de acción comentado con múltiples enlaces de información adicional en cada uno de los pasos. Información y Recursos en la Red sobre el efecto 2.000 Pero además de lo comentado anteriormente, Internet es una fuente de información incomparable que nos puede ayudar en situaciones más específicas. Así, por si se desea obtener información más concreta, presentamos a continuación algunos enlaces existentes en la Red de ayuda en distintos ámbitos. Son estos, enlaces muy genéricos que pueden servir como puntos de partida según el tipo de usuario al que van dirigidos ya que cada uno de ellos ofrece a su vez enlaces a otros muchos recursos Referente a las implicaciones más globales, la ONU ofrece su web dedicado al año 2.000 en el que se expone el problema de forma general y se dan recomendaciones en el ámbito de gobiernos y organizaciones internacionales. Además se ha puesto en la Red un informe ilustrativo de las medidas llevadas a cabo internamente en los diferentes sistemas informáticos para afrontar el problema. También existe completa documentación de un reciente encuentro celebrado en Nueva York abordando el tema desde los diferentes sectores (Telecomunicaciones, Electricidad, Energía, Servicios financieros, Aviación…). En la misma línea que el anterior, pero limitándose al ámbito continental, se encuentra el web dedicado de la ISPO (Information Society Promotion Office) de la Unión Europea. En él podemos encontrar informes de la Comisión Europea relativos a la situación en los diferentes países miembros y recomendaciones por sectores. De forma adicional se ofrece completa información sobre el impacto del Euro en las Tecnologías de la Información. Dedicado a las operadoras y empresas del sector, se encuentra el web del Year 2000 Task Force de la UIT (Unión Internacional de Telecomunicaciones). En él se ofrecen los interesantes informes y actas de los diversos grupos de trabajo dedicados a este tema (Operadoras, Gestión de la Información, Desarrollo, Planes de Contingencia…) constituidos por expertos de diferentes empresas y entidades del sector. El efecto del año 2.000 sobre las telecomunicaciones en España es el leit motiv del web dedicado de la Secretaría General de Comunicaciones. En él se exponen las actuaciones del Gobierno, las propias de la Secretaría y otras iniciativas de carácter nacional e internacional. El MAP (Ministerio de Administraciones Públicas) ofrece un web dedicado a la adaptación de los sistemas de información de las Administraciones Públicas al Euro y el año 2.000. En él, además de acciones legislativas, de sensibilización y difusión, podemos encontrar publicaciones, formación e iniciativas, tanto en el ámbito público como privado (valgan como ejemplo las de la CEOE y la Cámara de Comercio de Barcelona). También posee un centro de servicios de información y soporte técnico en el que se dan respuesta a las preguntas más frecuentes, se pueden consultar informes diversos, así como otras iniciativas. SEDISI en su página web, además de información general, ofrece enlaces a las empresas incluidas en el "Directorio de Soluciones Euro/Milenio" elaborado por ellos mismos, así como datos estadísticos sobre la adaptación de los sistemas de información de las empresas españolas al año 2.000. Dirigido a empresas en general y particulares que deseen afrontar el problema, IBM ofrece un tutorial para preparar los equipos (Hw y Sw) de cara al cumplimiento del año 2.000. Y para finalizar, si tuviéramos que destacar un web, citaríamos el Year 2000 Information Center del consultor Peter de Jager. Se trata de una completa referencia sobre el tema con las últimas noticias, información sobre cumplimiento de HW y SW, grupos de usuarios, artículos, herramientas de prueba y enlaces clasificados a múltiples recursos. Prácticamente todas las empresas, instituciones y organizaciones del sector poseen en su web información sobre el año 2.000 en lo concerniente a sus actividades. En cualquier caso, aconsejamos desde aquí pasar una feliz nochevieja el próximo día 31 de Diciembre, pues como se dijera en aquella inmortal película: "Realmente mañana será otro día". -------------------------------------------------------------------------------- Direcciones de interés BUGS2000 www.dove.net.au/~omalley/intro.html FCC Y2K Site www.fcc.gov/year2000/y2kguide.html Internet Engineering Task Force (IETF) www.ietf.org Internet Architecture Board (IAB) www.iab.org IBM www.ibm.com/ibm/year2000 ISPO www.ispo.cec.be/y2keuro/year2000.htm MAP-Adaptación de los S.I. de la Admon. al Euro y Año 2.000 www.map.es/csi/pg7020.htm MAP-Centro de Servicios de Información y de Soporte Técnico www.map.es/a2000 ONU www.un.org/members/yr2000/ Secretaría General de Comunicaciones www.sgc.mfom.es/efecto/top_efec.htm SEDISI www.sedisi.es/f2000.htm UIT Year 2000 Task Force www.itu.int/y2k Year 2000 Information Center www.year2000.com -------------------------------------------------------------------------------- Juan José Sánchez Aguila-Collantes Ingeniero de Telecomunicación por la UPM En la actualidad trabaja en Ericsson [email protected]
30 oct 2015